• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

Speedo Deado


NAXJA Member
NAXJA Member
Sorry for the length of this post.


Speedo froze, not the cables or speedo drive at trans. Managed to free the drive in the speedo by soaking the end in some 91% IPA and spinning by hand and drill.
Seems fine now and speed reads consistent with GPS (on WAZE).

Full story

Went to do an errand and my speedo was stuck on zero. No movement, not even odo (not a DS9 reference). Thought maybe one of the cables broke. For those that don't have a Renix with cruise control, the speedo cable is in 2 parts, a short "upper" and a long "lower" cable. The upper clips onto the speedo. The other end has the CC speed sensor threaded on and then the lower cable continues through the firewall and to the trans (or tc if 4wd). It just so happens I did a salvage yard run the day before and managed to pick both cables and the sensor from an '89. So, this should be fairly easy.

Well, not so fast. Since the upper cable has the sensor attached, there's not a lot of slack to pull the cluster clear and disconnect it. Instead, I have to reach under the dash and unthread the nut holding the upper cable to the sensor and pull the cluster with the upper still attached. Once the cluster was out, I could reach in and turn the inner cable on the lower with my fingers. Since it spun relatively easy, I assumed it snapped along its length somewhere.

So, under I go to disconnect the cable at the speedo gear. Cable and connector are pretty dirty but no issue getting it off. Turns out the cable is not broken. When I pulled the cluster, the inner cable slipped out just enough for the squared end to slip out of the speedo gear. Must be the upper cable or the cc sensor.

So, I unclip the upper cable and it seems OK as does the sensor. Hmmm. So, I attach the sensor, upper and lower cables together (no cluster), get my lovely assistant and a drill, crawl back under and spin the cable with my drill. She confirms that the other end is spinning. Huh... Cables are good. Must be the gear. Take the speedo gear out and it's also good. Well, that only leaves the speedo itself.

I stick a small square end tool into the drive and give it a spin. It's frozen, won't turn. I open the cluster and remove the speedo. No obvious signs of corrosion or breakage. It simply won't turn. So, I did what any other would do, I used more force and it began to turn. It was stiff at first but got a bit easier the more I turned it (no power tools yet). Stopping to take a closer look, I still couldn't see any signs of damage, heat marks or anything else that could account for this. I put the tool back in to twist once more and it's stuck again. Twist harder and it begins to turn once more.

So, this must be some kind of lubrication issue or corrosion inside the drive "shaft" I can't see. I tried some lubricant. Now I'm using a drill to spin the speedo, slowly at first, then faster as it freed up. Using the drill, I could get the speedo up to about 45mph. However, once I stop spinning it starts to freeze up again. OK, so spray doesn't work, maybe soak would. I get a small container and fill it with 91% IPA (isopropyl alcohol) and immerse the drive end deep enough to cover it without getting the rest of the speedo in it. About an hour later, check it. It's better but not done so back in. After a few more cycles, the drive spins fairly freely. Using my fingers, I can make the speedo jump to about 50 mph. I get some light grease to touch up the odo gears, slap the whole thing back together and reinstall the cluster. While the cluster was out, I took the opportunity to replace some of the bulbs that were out.

This part I always hate. Again, since there's little slack in the speedo cable, I have to attach the sensor to the lower cable, put the upper cable on the speedo, install the cluster while guiding the upper cable past the dash structure and wire bundles behind it. Once in, reach under the dash to try and align the upper cable to the cc sensor and tighten the nut without cross threading it. Of course, fish the electrical connectors back into place and secure them. Must be done before reattaching the speedo cable.

Now that everything is back together, out for a quick test drive. Seems to be OK. Needle is a bit twitchy but speed compares nicely to GPS speed using WAZE. Back to the driveway. A final check and all seem good. No "extra" screws left.

So, I go on an errand a short while later and speedo still seems ok. Twitchiness has reduced, speed still matches gps. Go to make a right turn, turn on my turn signal, I hear the clicking, but there's no flash on the dash. Make my turn. Tried left, left light works. Bulb maybe? Right side worked before all of this.

Get back home, check that the turn signals do actually work, just no indicator. Perhaps I didn't seat the bulb correctly when I checked all of them. Better check the other cluster lights. So, I pull the headlamp switch on to check the high beam light (engine off, key on). Suddenly, all of the electrical gauges go haywire. Turn the lights off, everything back to normal. On again, haywire again. <sigh!> Not the bulb, must be one of the connectors. So once more unto the breech (er, I mean cluster) I go. I thought I could pull the cluster forward just enough to check both connectors. I could get to the one on the left side (behind the warning lights) but it was in solid and latched. I couldn't reach the central one with the speedo cable connected. The cable end that attaches to the speedo is plastic, mine is cracked but usable. The '89 I grabbed is also cracked (no lock tab) so I don't want to risk breaking the cable. So back underneath to detach. Now I can pull the cluster far enough forward to reach the other connector. Sure enough, I didn't get it full seated. Press again and it snaps into place. Put everything back together (again). Test the lights, all good. Short test drive, speedo good. AT LAST!!

I actually did this a few days ago. I wanted to get a bit more driving and overnight sitting to see if the speedo continues to function. So far so good.

Here’s a few pics for your enjoyment.

Speedo taking a bath


Dash w/o cluster. This is the connector that I didn't fully seat


Cluster w/o speedo. Always thought it was strange that some of the gauges don't read zero when disconnected.


The cracked clip on the upper cable. A couple of zip ties keep from coming off.


Here you can see the "barrel" where the cable clips. This is where the drive "froze" and ended up in the tub.


Last edited:
Man, you got my hopes up.

I thought there was finally a use for all these IPA beers.

Turns out you meant something else instead.

Story of my life.

Good write-up. Likely to be useful to someone. The older these vehicles get the more interesting problems are going to occur.
Actually I did have a few IPAs (Ballast Point)) afterwards and became braino deado.
"Victory at Sea" is where it's at.