• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

98 XJ manual ignition problem


NAXJA Forum User
Hi all,

Just bought a 98 2wd 5-speed 4.0 in great shape with only 130k original miles. I bought it in a crank, no start condition. Been working on it several hours now, and I'm stuck. Here's what I've done:
  1. Tested the battery already in the car. Although it would turn the motor over, it wasn't really reading out any voltage, so I pulled it and replaced with a known good battery from a running 4.0, cleaned connections, etc.
  2. Did continuity test on all fuses under the hood. All good. Also tested fuse 11 in the kick panel as I read somewhere that it was involved. Also good.
  3. Tried to start it with a spark plug tester. Engine would turn over but NO SPARK indicated. I also don't hear the fuel pump prime and there is no fuel in the rail when I push on the Schrader valve. I figured I may have a dead fuel pump in addition to something else, so I decided to focus on the spark issue first.
  4. Checked CPS by confirming infinite resistance on pins B to C. Tried to also do the pulse test, but had trouble doing it alone, and not sure I'm doing it correctly anyway. CPS could be a problem, but I don't believe so at this point.
  5. Found that the ignition coil was not bolted up to the engine (and therefore not grounded??). I pulled it, tested it, and everything tests in range, so I have a good coil.
    HERE'S SOMETHING WEIRD: When I re-connected the coil and bolted it up so it would be grounded, now I have a NO CRANK scenario. Not sure why grounding a known good coil to the block made things worse.
  6. Checked power coming into the coil. difficult to see which wire is which, but with the battery connected and the key in the run position, I get NO VOLTAGE on either pin of the connection coming into the coil. Not less than 12v, but 0v.
  7. Pulled relays for ASD and fuel pump. Tested the relays with a meter and they seemed healthy. Switched them with some I believe to be working (and also tested good) and tried again. No dice. I also checked for 12v coming into pin 30 from the PDU and it was good for both.
So now what? I'm not a mechanic, but I'm trying hard to use Youtube to get me through this. At present I'm thinking ignition switch issues maybe? Not sure how to test that without replacing the part. I'm open to all suggestions. Such a high potential jeep, I gotta get this figured out.


I have found and fixed 1 issue. My jeep was equipped with an aftermarket immobilizer called a "Silencer". Figured out that it was the cause of my new no-crank issue, so I removed it and jumpered the break in the starter wire on the ignition switch harness (yellow). I tested the other wires to make sure they function like they are supposed to:
  • Red: Constant 12v
  • Blue: 12v when in the key is in the run position (actually only like 11.8v, but that should do something)
  • Yellow: 12v when the key is in the start position
Cool, but still crank, no start. Still no constant 12v to the back of the coil. Still no fuel pump pressure noise on key turn.

I'm going to assume now that the ignition switch and harness are doing what they're supposed to do and look downstream for the problem. I'm also going to assume, for now, that this isn't a ECM issue, because I'm going to have trouble finding one of those and would rather eliminate everything else. Any suggestions on what to check next?
When you turn the ignition ON, the fuel pump should run/prime for 3-5 seconds, prior to turning the ignition to START.

I would start with continuity testing and voltage test of the fuel pump wire harness.
Checked CPS by confirming infinite resistance on pins B to C. Tried to also do the pulse test, but had trouble doing it alone, and not sure I'm doing it correctly anyway. CPS could be a problem, but I don't believe so at this point.

Measuring resistance on an HO crank sensor doesn't tell you anything. The older renix ones you could test the resistance, but not the newer ones.

Try measuring the output with the meter set to a/c. Or try replacing it, although keep in mind that cheap chinese sensors are pretty poor quality and the odds of getting one dead out of the box is non-zero.

Thank for these suggestions. I have considered that the CPS might still be bad, but I think I have bigger problems, maybe a combination of several.

Yesterday I thoroughly tested the ASD relays and found that they were good. I made a jumper to basically bypass the ASD just to see if I got a constant 12v to the back of the coil. I did! So, the ASD relay works and the circuit seems at least partially good (still no fuel pump though), but the computer isn't communicating with it or is sending garbage.

So I tried to hook my code reader to the ODB socket and check for faults, but there's no communication to the computer. That could indicate that the computer is bad, but that's the last thing I'm going to try and replace in a manual XJ because they're hard to come by and $$.

Next I tried testing my 5v reference to my CPS, and it was no good. Got about .7v on both pins 1 and 3. Same thing on the pickup coil. That's where I had to stop.

I think that 5v circuit might be the root of the problem. I'm going to unplug all the sensors and see if I can get it back up to 5v. If that doesn't work I'm going to start looking at grounds. I've already visually checked the harness, but I havent pulled and cleaned grounds yet.

If neither of these improve things, is my computer dead? I saw where a guy found a dead ground in the ecm that caused all this, and he just cut that wire and grounded everything to the chassis. Would love to hear everyone else's thoughts.

Sent from my SM-G998U using Tapatalk
The symptoms suggest a failed CPS, or another one of the 5 volts OBD engine sensors. ECM/PCM failure is very highly unlikely and should only be consider after thorough and in-depth diagnostics of the more common and more logical suspects for the symptoms described.

When the ignition key is first turned ON, 12 volts travels from the ignition switch to the ASD relay. The PCM provides ground to the ASD relay to energize it. The ASD relay sends the 12 volts to the primary side of the coil. If after a few seconds no signal is detected from the faulty CPS, the PCM opens the ASD relay and 12 volts power to the coil and fuel pump is removed.

If the CPS/CKP is failed sometimes the OBD-II code reader cannot make a connection to the computer or cannot read Check Engine Light/MIL codes because the CPS/CKP has failed.

Crankshaft Position Sensor (CPS) located on the transmission bell housing. Often this part is also referred to as the CranKshaft Position Sensor (CKP). CPS/CKP failure is very common. The CPS/CKP can stop working with no warning or symptoms and the engine will not run or the engine may randomly stall for no apparent reason. Typical genuine Jeep CPS lifespan is about 150-200,000 miles.

Crank Position Sensors can have intermittent “thermal failure”. This means that the CPS/CKP fails when the engine gets hot, but works again when it cools back down.

Typical CPS Symptoms, (not all symptoms may be present, or occur at the same time) -
- Random stalling
- Starter cranks and cranks but engine won't start up
- Fuel gauge and voltage gauges may not work or display properly.
- You sometimes will have NoBus displayed on the odometer after 30-60 seconds.
- A failed CPS/CKP may or may not throw a CEL trouble code.
- Fuel pump should run and prime for 3-5 seconds.
- No spark at the spark plugs.

Diagnostic steps to help confirm the CPS is the cause of your no-start:
-You should be able to verify a bad cps, by unplugging it, and turning the ignition key to ON. If the voltage gauge and/or the fuel gauge now displays correctly, replace the CPS.
-Unplugging and reconnecting the CPS sensor where it connect to the main harness near the back of the intake manifold usually resets the ECU and if the jeep fires right up after doing this you can bet that the CPS is faulty and needs to be replaced.
-Exchange the fuel pump relay and the ASD relay with one of the other similar ones in the PDC to eliminate these relays as the cause of the no-start. Confirm that the fuel pump runs for 3-5 seconds when you turn the ignition key to ON.
-Eliminate the NSS as a cause of no start. Wiggle the shift lever at the same time you try to start. Put the transmission in Neutral and do the same. Do the reverse lights come on when the shifter is in Reverse?
-Inspect the wires and wire connectors at the O2 sensors on the exhausts pipe. A short circuit from melted insulation or from broken O2 sensor wires can blow a fuse and the ECU/ECM will lose communication.
-Check the ground connection for the PCM. Make sure it is clean, snug, and has no corrosion.

CPS Testing
TESTING PROCEDURE 1991 –2001 4.0L H.O. engines
1. Near the rear of fuel rail, disconnect sensor pigtail harness connector from main wiring harness.
2. Place an ohmmeter across terminals B and C or 2 and 3 (See Image). Ohmmeter should be set to the 10K-or-2OK scale for this test.
3. The meter reading should be open (infinite resistance). Replace sensor if a low resistance is indicated.

If you buy a new CPS, get a genuine Jeep CPS. Most auto parts stores sell cheap crappy Chinese "Lifetime Warranty" parts that are poorly manufactured from inferior materials and are often out of specification, or even failed, right out of the box. The ones that aren’t faulty often have a short service life before they fail. Always buy top quality replacement parts and genuine Jeep sensors. Numerous threads detail long and frustrating searches for a "problem" that ended up being cured simply with genuine Jeep repair parts. Buy good quality repair parts and genuine Jeep sensors for best results.

You must also perform basic trouble shooting of the start and charge systems. Remove, clean, and firmly reconnect all the wires and cables to the battery, starter, and alternator. Look for corroded or damaged cables and replace as needed. Do the same for the grounding wires from the battery and engine to the Cherokee's frame/body. Jeeps do not tolerate low voltage or poor grounds and the ECM/ECU will behave oddly until you remedy this.
Thank you Tim_MN for such a thorough response. I do have some follow-up questions:

I believe as you do that PCM issues are rare, and I'm trying to prove that. I also believed that my issue was CPS or one of the other sensors, but I'm going down the rabbit hole with my voltmeter now, and I don't think thats the case anymore. I found this video from ScannerDanner:


I used that as a guide along with the PCM pinouts from this manual that I found online (relevant pinouts on 8W - 80 - 83):


I basically did everything that ScannerDanner did up to about the 6:30m mark.
  1. I have verified 12v on pins A2 and A22.
  2. I have verified good grounds on A31 and A32.
  3. I have tested my 5v reference on pins A17 and B31. They are both about 0.7v
  4. I have systematically unplugged almost every sensor on the wiring harness to watch for a change in voltage, but no dice.
  5. Rather than cut the wire on B31, I just unplugged the whole B connector at the PCM, and there was no voltage change to A17.
  6. I have visually inspected my harness and not immediately found any damage, and I only had 2 blown fuses which were the 12v cabin power port and the 12v cigarette lighter (25A fuses in the kickplate). I replaced those and no change.
  7. I still can't connect to the PCM with my ODB dongle.
So after all of that, have I isolated the PCM as the issue? I can't get that 5v output to come up to 5v after everything I've tried. If there's a good 12v supply, and good grounds, doesn't that seem like something in the computer is failing to convert/output the 5v that it should on those supply lines? Or, is there something I'm missing?

I'm in no hurry. Keep the suggestions coming.
I would try testing the pcm itself by unplugging all the connectors and applying only the grounds and12 12volt power then checking for a 5 volt output.
I would try testing the pcm itself by unplugging all the connectors and applying only the grounds and12 12volt power then checking for a 5 volt output.
That's a great idea! I'll try that.

On a side note, I have a PCM for a 98 automatic 2wd XJ, and I know it works. I realize the parts aren't interchangeable, but couldn't I use it for diagnostic purposes, like to prove that the original computer is bad?

Thanks, I'll let you know how that test goes.

Sent from my SM-G998U using Tapatalk
Did as suggested. With the computer completely removed and isolated, the grounds tied to negative battery, and the 12v supplies tied to positive battery, I'm still only getting .7v on the 5v outputs.

He's dead Jim.

Still curious about using my other computer in place of this one just to see if it'll communicate over ODB and maybe even start. Then I'd know for sure that I need to search for a 5 speed computer. Any reason I shouldn't try it?

Sent from my SM-G998U using Tapatalk
I dont see a reason not to try, I dont really know what the differences in the pcm would be since they use a Tim to connect thru the data link?
You would need it reflashed if you have to pass emissions.
If you have cruise control, try unplugging the steering wheel clockspring too. Shorts in there between the +12-volt horn and the cruise signal wires can cause odd symptoms like this too.
I dont see a reason not to try, I dont really know what the differences in the pcm would be since they use a Tim to connect thru the data link?

Well that definitely made a difference. I plugged in the auto PCM, turned the key on, and immediately got power on my ref lines. Still no ODB connection. So I reconnected all my sensors, and boom, connection came back. Definitely a PCM issue.

I ran diagnostics and got 2 codes:
  • P1698 - no communication with TCM (expected, its a manual)
  • P0463 - signal coming from the fuel tank indicates that there is more fuel than is mathematically possible for the fuel tank to hold
So, I'm thinking there's a short in my fuel pump. I noticed that I still didn't hear the fuel pump prime when I turned the key. I guess I could try to prove that before I start dropping fuel tanks, so I'm taking suggestions on how to do that.

Also, I'm apparently looking for a 98 5 speed PCM. Looks like Part# P56041531AE. Anybody selling?
They sell testing relays, I use mine to run the fuel pump when I'm trying to drain the tank.
Did you check the 12V supply to the sockets of the relays?
I was diagnosing a no start and found a lack of 12V to the fuel relay. After replacing the CPS, it started right up.
Did you check the 12V supply to the sockets of the relays?

I was diagnosing a no start and found a lack of 12V to the fuel relay. After replacing the CPS, it started right up.
Yes, I did. I was getting the 12v from the battery there. I think the bad 5v ref from the PCM was basically killing the ASD circuit and blocking 12v to the coil. When I swapped the PCM with the good automatic one that I have, I now get the 12v to the coil. Having isolated the old manual PCM completely and testing the 5v ref without any outside influences, I feel pretty confident that it was bad.

That, and I also have a bad fuel pump.

I'll update this post when it's fixed to confirm.

Sent from my SM-G998U using Tapatalk
Calling this one resolved. I drove this jeep for the first time today, even with the incorrect computer. Ultimately it was a bad computer AND a bad fuel pump. Replaced both, and she runs and drives. The only CEL I have is for non-communication with the TCM because I put the automatic computer in a jeep with a manual trans. For anyone that's looking, you can get replacement computers with a warranty at https://www.fs1inc.com/
FS1 has done me right, I'm on my third one and they have a lifetime warranty!