• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

Fuel pump will not prime

Patrick dimel

NAXJA Forum User
I’m at a loss, I have an 89 xj 4.0 remix and the fuel pump will not prime. I’ve tried jumping the relay no go, I tried jumping the resistor and no go, i just put a new pump in and nothing. I have power to pin 30 and and I have ignition power to 85 so I’m confused on why it’s not going. I’ve checked all chassis grounds and they’re good as well. Any help would be greatly appreciated
Are you checking for voltage at the fuel tank?
Well you need to start at the source (fuel pump relay) and follow it back to the fuel pump.
Well you need to start at the source (fuel pump relay) and follow it back to the fuel pump.
Are you saying that if there’s no power at the pump. Then there is a problem with the 87 wire that’s feeds the pump? Just want to make sure I understand.
That would be true as long as the fuel pump relay is still energized.
Does the relay click?

Also check your fusible links at the starter relay. One of them is for the fuel pump relay. Would go to pin 30 (pin 1 on XJ Schematic).
You are aware that it will prime at key-on and then shutoff the fuel pump after a few seconds if it's not seeing rpm? I just want to make sure you're not chasing your tail thinking it should be powered anytime the ignition is on.

Do you have voltage at the ballast resistor? Have you tried jumping power directly to the resistor? If that works, then the pump and wiring to the rear are good, and you're problem is under the hood.
If (with the key off) you jumper 30 to 87 the fuel pump should be constantly on !!!
Is this the same XJ your dad has been posting on?
You said you have power to 30, so there is failure between 87 (at the relay/PDC) and the fuel pump.
The other possibility is the pump itself, have you tried applying power directly to the pump?