• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

No Start After Welding, Fuel Gauge Not Working. I'm seriously confused.


NAXJA Forum User
So I welded to my roof rack last night...at about 10pm, outside in the snow in 20F weather in a short break between snow flurries. It was about the umpteenth time I've welded to my Jeep. I disconnected the battery and ECU like I always do, finished welding, hooked it back up, and no start. It cranked fine, I could smell fuel, I could hear the pump, but it would not start. No codes, but O2 and a few other smog categories were flashing. I fried an ignition coil once when I shorted the battery to the block so I replaced the coil thinking maybe I fried the coil. Still nothing. I checked all fuses and relays. They were fine. I bypassed the alarm, still no start. I swapped ECU's, still nothing, so I put the old one back in. At midnight I crawled under the Jeep in the snow and replaced the crank position sensor with some very cold hands. Still no start.

It was 2am at this point and I was about out of ideas, and I needed to get up to leave for work in 6 hours, so I sat there trying to starting it and pushing on the gas pedal. Well, it fumbled. I tried again and it started, but ran very rough and the idle went from low to high then finally settled on a normal idle after a minute or two. It acted like the IAC was out of whack. Turned it off, started it again no problem. The fuel gauge now reads overfull even though it has half a tank though.

I don't get it. What happened? All I can think of that went differently this time is I had bad ground on the welding clamp at first and had to reposition it. Maybe the welder charged up the Jeep's ground like a capacitor? I've had bad grounds on my welding clamp before though. Could this have caused the IAC to close and fried the CPS when the battery and ECU were disconnected?

I'm planning to take this Jeep desert camping in the snow soon...very, very far away from the highway. I'm nervous guys. Does any of this make sense? What happened to the Jeep? Any idea why the gas gauge doesn't work now, or how to fix it?
Where was the ground attached?
That pretty much means that evrything else is just coinsidental! I would be looking at poor wiring/connections. What year is it?
Btw, what you welding with, ac or dc?
I've welded on my 95 many times without disconnecting anything, this has got to be a coincidence, I'd double check and clean all grounds again.
I‘m suspicious of this being a coincidence tbh. At least two things failed, possibly 3, immediately after welding. The Jeep is maintained immaculately and has never broken down. I know it seems strange, but that’s just a really big coincidence.
This doesn't answer your questions but since you mentioned a poor welding ground...I replaced my welding clamp years ago with this vice grip hack...works pretty good.

All of my XJ's have been earlier model years ('90/'93) but I have been working on a '2003 Chevy S10 recently and am finding that if I disconnect the battery for too long (while working on the vehicle), it not only loses its emission counters but also loses its adaptations for throttle. In fact, I replaced the battery a couple of weeks ago and left it disconnected for a couple of hours. I expected to lose my emission counters but I was surprised when I also experienced symptoms similar to yours. Essentially, the ECU has been adapting the throttle position data for the past 20 years and this extended battery disconnect caused it to forget how it had adapted. The end result is that when I first started it, it would rev up and then drop to a stall. It did this 4-5 times but eventually got a little better so I took it for a short ride only to find that it was stalling every time I came to a stop.

The "fix" was to limp it back to my driveway, start it and play with the throttle until it got up to temperature and entered "closed loop" mode. Soon after that, the ECU figured out what was going on and rebuilt the adaptations. It has run perfectly ever since.

Any chance you left the battery disconnected a little longer than usual?