• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

Help Please


NAXJA Forum User
I have a 91 xj, with 6.5" rusty's lift on 33s. I am unable to get it to start, when I turn the key I can hear the fuel pump in the back, but it will not spin the starter, not even a click. I put a charger on the battery, as well as even took the battery to get checked to see if this would alleviate any problems, cleaned the posts and clamps, as well as checked the ground, as well as the starter connections. Everything to check out okay...however, when i look at the battery meter in the cab, it shows to be between the middle and dead (closer to what I would consider to be dead) is that normal. I was told that it could be the neutral safety switch, but upon jogging it back and forth from park through all the gears, it will still not make a sound. Any help would be appreciated. Oh yeah, I was glad to see that there was a forum for the cherokees, as I know with my other vehicles that seem to be very helpful. Thanks, Dan
Sounds like the sylonoid on the starter went out. I would take the starter to an autozone to be tested or test it your self with jumper cables. normally if it is the nss you can still start it in neutral.
actually, it sounds like a dead battery. your fuel pump only needs about 6 volts to operate, so just because you hear it running doesnt mean the battery is fully charged. a load test on the battery will be the first thing to check. you can even try putting your headlights on and then try cranking it over. if the headlights dim to basically nothing, your battery is most likely toast. if the battery checks out fine, next id take a better look at the nuetral safety switch. make sure the under hood connection didnt come loose or dirty. just because you tried moving the transmission selector through the gears, doesnt mean its not the switch. my NSS was so bad that when it wouldnt start in park, it didnt in nuetral either. sometimes took me a good 5 minutes of playing around with the selector back and forth to finally get a contact. check your reverse lights, if they dont turn on with the key on and selector in reverse, your probably looking at the NSS. if you feel the starter selenoid is the culprit, try jumping with a good battery or charger and use the screw driver trick to jump contacts straight on the starter.
As 2stix mentioned, you can test a lot by using a screwdriver or similar to jump current from the big heavy post on the starter (which is always powered), to the small solenoid terminal also on the starter. Make sure you are in PARK. Otherwise you COULD run yourself over. If it starts like that, you know that your starter, battery, and main wire in between is good. That would get it down to the NSS, key switch, a few other parts, and the wires in between.
Mine is starting to do the same thing, but battery reads 12.9V and the alt. is charging at 14.8. Get under it and hit the starter with a hammer and it starts normal. Seems the starter has a dead spot, needs to be replaced. Of course my OFA has been soaking my starter with oil for over half a year as well.
first check your battery then press foward on the shifter and try to start it.

Bad nuetral switch can cause that to happen
Was battery "load tested"? Load testing is the only conclusive way of determining battery condition.

Assuming battery is good, I'd put a meter on the starter with the key in the ON position. You should have approx. the same voltage at the starter that you have at the battery.

If you do have 12 volts, then you have a starter problem. If you don't, you need to start working your way backwards to find out why. NSS is still very much in play here; do you have backup lights? As mentioned, the backup lights are part of the NSS circuit. If the backup lights aren't working, that is a smoking gun that it's the NSS. If they work, that doesn't necessarily mean that it ISN'T the NSS though. Also the starter relay in the power distribution center under the hood is in the loop.

Good luck and let us know what you find!