• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

OBDII Linking Error

hbar..

New member
Helping a friend with his 99 XJ, has a CEL but is unable to read the codes because it keeps saying "Linking Error" when it tries to connect. The reader will power up no problem, just no communication. And the key on 3x trick doesn't seem to put codes on the odometer, but I've literally never gotten that to work on any jeep. Also, the jeep starts and runs, zero issue. Nearly every thread out there on this topic has to do with bad grounds or a faulty CPS, and seems like usually the jeep won't start; this is not our experience. We also have no fuel gauge or speedo, BUT we also just removed the transmission so it's possible something got jacked in that wiring along the way. Willing to treat that as a red herring for now.

There are 7 wires in the OBDII connector (called the Data Link Connector in the FSM):

Pin 3: CCD Bus (+), VT/BR wire. This has ~4V on it with the key on. I expected this to be between 0V - 5V, so I think it's ok.
Pin 4: Ground, BK wire. This has continuity with the chassis, so I think it's ok.
Pin 5: Ground, BK/TN wire. This also has continuity with the chassis, so I think it's ok.
Pin 6: SCI receive, LG/BK wire. This has ~3V with the key on, and has continuity all the way to pin 29 on C3 at the PCM. I think it's ok.
Pin 7: SCI transmit, PK wire. This has 0V on it, but since we aren't transmitting anything, that's probably ok. It has continuity all the way to pin 27 on C3 at the PCM. I think it's ok.
Pin 11: CCD Bus (-), WT/BK wire. This has ~4V on it with the key on. I expected this to be between 0V - 5V, so I think it's ok.
Pin 16: Fused B(+), TN/BK wire. This has +12V on it at all times, which is expected. I think it's ok.

So, I've basically tested every wire and have not been able to identify a problem. The instrument cluster appears to be fed by those CCD bus wires, which also go to the DLC...so if you have info at one place, you should have it the other. What I'm hoping for by posting this is that we have an OBDII guru here who can help with some other diagnostic tests to figure out what is going on.
 
Some lesser quality OBD-II trouble code readers have difficulty linking to the Cherokee PCM. Have tried a different Code Reader and get the same result ?

Have you checked all the fuses ?

Here some info I saved from another Jeeping forum.



DLC = Data Link Connector for OBD-II diagnostics.

The voltage in the OBD II diagnostic connector is charging voltage. It is about 12-12.6 volts engine off. It is about 13.9-14.4 with the engine running.

Check the fuses, if the cigarette lighter fuse is blown sometime the OBD-II port has no voltage or low voltage.

JeepForum member CCKen posted this:

Go to the Data Link Connector.

Top row of pin cavities, the second and third occupied cavities (from the left) are the ground cavities for the DLC. They go to the oil dipstick tube mounting bracket stud on the left side of the engine.

The pin cavity on the far right on the bottom row is the 12 VDC power supply to the DLC.

Using a voltmeter, measure from the one of the top row ground pin cavities to the power pin cavity on the bottom row, you should see 12 VDC. If not, switch to the other ground pin cavity. If still nothing visually check the two wires at the oil dipstick ground point. If they are intact and free of corrosion, use an Ohmmeter to check the ground wires from each of the ground pin cavities to chassis ground. You should see continuity (.5 Ohms or less).

Power to the DLC comes from fuse F17 in the PDC. If it were blown other circuits powered by this fuse would be inoperative as well, such as the headlamps or cigarette lighter.

Pin cavities on the DLC must be corrosion free and not have expanded pin cavities from Bubba shoving meter probes in the cavities.

The above is for powering up the scanner only. Not being able to "Communicate" is an issue with the Serial Communication Interface (SCI) function of the PCM. The issue may be the SCI Transmit wiring, or internal problem related to the PCM, TCM, or ABS CAB.
 
yep, read most of those posts elsewhere, and most of those diagnostic tests have been performed and the results are in my first post. I don't have a ground wire on the dipstick afaik, but I do have continuity with the chassis when I test against pins 4 & 5.

We've checked fuses several times over the past few months, this particular issue has been going on for some time. We're not aware of any other functions that aren't working properly; the Jeep drives fine.
 
Regarding those grounds, I've traced all the wires in the FSM wiring diagrams, and pins 4 & 5 are grounded at G102. Unfortunately, G102 only appears in the diagrams for the diesel engine in the Connector Locations chapter (8W-90) of the FSM. I don't know if that's a mistake or if all the ground references in the wiring diagrams are wrong.
 
try this.

Unplug the CPS and then connect the reader

If there's a trick that's been posted here, I've probably read about it. Plugged, unplugged, makes no difference. Seems like the people that works for also have a no start condition, but this jeep runs fine.
 
<snip> We also have no fuel gauge or speedo, BUT we also just removed the transmission so it's possible something got jacked in that wiring along the way. Willing to treat that as a red herring for now.

This is where I would look more closely. If you suspect there may be some harness damage, at least you can rule this out.
 
The no link issue has been present for months. The no fuel/no speedo only showed up after we dropped the transmission. That said, I had the same thought, but we tested that wiring and found no issues.
 
All types and brands of code readers don't link, or just yours ?
 
His reader doesn’t work, haven’t re-tested mine since we got the new computer. But it seems like a good time to mention that at one point we threw a 2000 computer in there and it was able to link up. Then when we put the 99 back in, no link. And with the new 99 from WranglerFix, back to no link.

But that was months ago that we did those tests.
 
I get the "No Link" sometimes only after I try to clear the codes, on my cheap reader. What I get it to do to read is once it connects I go to the live info (ie, engine temp, rpms, throttle position, ect) once it reads those I can access the codes and clear them.
 
We tried to connect my Zurich ZR8 (the mid grade Harbor Freight model) and it did not give a link error but neither would it read any codes. In fact it said there were none, and it also said the vehicle did not support live data reading, but I know that's false. And FWIW, this particular reader used to be able to read codes off this particular jeep.

Then I plugged in my bluetooth OBDII reader that I got for Christmas. And sure enough it linked right up, read live data, and showed us 3 codes, including a P1694 which is a brand new one to me, but looks to be something of a chicken & egg situation. It describes a problem with the BUS, but it tells me that on the BUS. Whatevs, at least I have a new problem to chase down.
 
Another update.... we unplugged a bunch of sensors & TCM, no change. Plugged them all back in, and my buddy (whose jeep this actually it) got his "lesser" reader to read codes. I'm not sure what we did after that, but for no *apparent* reason his reader started giving a Linking Error again.

I did notice some suspect wiring around the TPS/IAC area, and now I'm wondering if there is a short or something in that section of the harness that allowed the reader to connect after we had jiggled stuff around. I think our next order of business is to replace a connector and peel back the harness in that area. I've never opened up a jeep wiring harness and NOT found an issue, so this should be enlightening.
 
We're getting intermittent linking, and the only thing we're messing with the the wires around the IAC & TPS so I'm pretty well sold on this being a wiring issue. We can't reliably make it link/not link but that little section of the harness is all we've touched.
 
try touching the harness further out on either side.

I didn't mean that to be so literal. We've moved around the harness in that general area. It goes directly into the fuel injectors so there's not much play there. The other end goes down to the CPS but the whole issue is so hit & miss.

Going wheeling this weekend, so we're going to leave well enough alone for now. After that we'll open up that harness and see what sort of mess we find.
 
the key on 3x trick doesn't seem to put codes on the odometer, but I've literally never gotten that to work on any jeep.

Little late to the party here (and I know it sounds like a different reader got you codes), but noticed the bit about the key on-off trick.

Far as I know, that only worked on the 91-95 XJs, and it used the CEL lamp to blink out the codes (I've used it on my '92 a number of times). I've never heard of a key trick that worked on the OBD-II models.


Rob
 
I've got the key trick to work on my 02 TJ, but not on my 97 TJ.

The problem is so hit & miss, we don't know if different readers work better, or if it is purely something under the hood. He's buying a harness off a wrecked 99 XJ and I think we're going to wire it in tonight. It will either make everything better or it won't.
 
Next update. Picked up a "like new" harness off a 2WD 99, well really just the section that includes the TPS/MAF/IAC/crank & cam sensors. Harness was in great shape, am thinking it was a replacement due to the overall color & condition of the loom. Anyway, you probably knew that the 2WD harness didn't have the wiring for the 4WD light. But you probably didn't consider that the wiring for the speedo is a decent amount shorter since it doesn't have to reach the transfer case. Also the oil pressure plug is ever so slightly different, but we can worry about that later.

Anyway, new harness, still initially got a linking error. Fired the thing up w/o any problem, and then it linked. It was already 1am so we didn't mess with it any more.
 
We ended up inspecting every inch of the original harness, and replaced the couple of connectors that were in bad shape and a few lengths of wire that were bare or brittle. Unfortunately nothing changed with respect to our ability to read codes. It was still a worthwhile exercise. I've re-taped & re-loomed several XJ & TJ harnesses, and every single one of them has had some hidden wiring issue that was just waiting to ruin your day.

However, I recently got a new bluetooth reader so I brought it over and tried it on his jeep, and it connected right away. I know somebody suggested either in this thread or a related thread that XJ's seem to be picky when it comes to readers. I guess I can live with that, but it still strikes me as extremely odd that 2 different readers that used to work fine now won't communicate. But I guess this is resolved for the time being.

Thanks everyone who followed along.
 
Back
Top