• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

No Spark


NAXJA Forum User
I have a 1992 Cherokee with a manual transmission. The other day it was running great and had been for a while. I recently replaced the water pump and shortly before that I had a shop do U-Joints, thermostat and power steering pump.

Like I said it was running great and I turned it off and parked it and came back a few moments later and it cranks strong but wont start at all. I get it home and try again and the starter cranks fine but no start and I can smell gas.

So I check for spark at the plugs and nothing. I put a multi-meter on the coil primary with the ignition on and I have 12 volts between positive and negative terminals on the snap-in connector. I pull the coil secondary wire off of the distributor and turn the motor over and no spark there.

I also replaced the spark plugs, wires, cap and rotor maybe a year ago.

I removed the ignition coil from the Jeep and test it with my meter. I get primary to metal body = 0 ohms, primary positive to negative = 1 ohm and primary to secondary was (I forget) but it was a lot of ohms, like 6k or 6 megs or something.

I checked the fuses in the engine compartment they all look good. And quickly looked over the fuses in the cab but didn't see anything that looked ignition so didn't get into it.

I have replaced the crankshaft position sensor and the sync signal generator module (inside the distributor).

I have a Haynes and the factory manuals and reading through the factory manual on the ignition system the only device that it specifically says the engine will not run without is the crankshaft position sensor. So I haven't gone through and tested the other sensors: Coolant Temp Sensor, Manifold Air Temp Sensor and Manifold Absolute Pressure Sensor.

I might have access to borrow an ignition coil tomorrow to test it or I can buy one for $70 but I think that it looks good. But if it's not bad and I have power to the coil primary would the lack of the Engine Controller interrupting the the primary negative on the coil make it so that I don't see a spark? (I say this because the manual says that the Engine Controller controls the timing through the negative of the coil's primary.) So maybe the Engine Controller isn't pulsing the ignition coil's primary and a steady coil output would do what to ground? IDK.

So what could I be missing here? Where to look next? Replace the coil or Engine Controller?

Any help would be highly appreciated.

The fuel injectors pulsing? No I haven't looked into the fuel system. How would I test for that? I can read up on the fuel system tomorrow. Is your reasoning maybe a bad Engine Controller or the Sync Signal Generator Module (inside the distributor)?

I haven't tried to test for pulsing to the primary of the ignition coil. I don't know if I would see that with a digital multi-meter. It seems like it would be happening to fast for the meter to see it.
If you don't have a test light, try putting the voltmeter in A/C mode to look for pulsing. On a cheap meter, you might need to try with the leads swapped (ie the red wire on ground) because of the way it measures a/c.
You might try swapping the ASD relay
with a similar one (located in the fuse
center under the hood).

If the relay is sticking, it could be interrupting
the spark...
I fixed it. It was the coil. Funny the new one read almost exactly the same as the old one. The old one was 8k ohms between the primary and secondary windings and the new one is 9k.

Neither one read any continuity between the primary to ground (casing body) or secondary to ground. The old one did have a big crack in the casing though. And now that I think about you can't read a high voltage short with a normal multi-meter. You need a megger that usages a very high voltage that will drive the current across failing insulation.

Now I have a spare crankshaft position sensor and the sync signal generator module (that I'll never be able to find again). Oh well, it's not the destination but the journey.

Thanks so much for your help!

Glad you got it fixed, and thanks for
posting what fixed it. This could have been
a tough one since the coil "tested" good...