• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

No Fuel, No Spark, No Dash....


NAXJA Forum User
Juneau, AK
I picked up a '98 Cherokee awhile back for pennies (of course) as it's a salvage title. The vehicle had been in a front end dinger popping both airbags. The previous owner replaced all the sheet metal (now it has a '93 front end) but it will not start. I have the ATX and 4.0L HO engine, 4x4. Vehicle was loaded from the factory.

So far I have replaced both airbags (one pending, but on it's way) and the airbag ECU under the center console. I reviewed this thread completely, and replaced my CPS with no change. I have the following symptoms:
  • No fuel pressure, fuel pump does not run with key "ON"
  • No spark from coil
  • Left side of dash is DOA (voltage gauge doesn't move when you key "ON", left turn signal no workee, .... right side seems to work okay)
  • Code P1496 (no CCD bus signal?)
  • Fuel gauge doesn't rise, but vehicle HAS over 1/2 tank of fuel but it's also on LHS of cluster.
I have done the following, besides the new CPS:
  • Tested fuel pump with battery, good.
  • Replaced coil, still no spark
  • Checked plugs, etc but w/no fuel or spark that's moot....
  • new battery
  • Checked all relays. Two ignition relays show HOT when key "ON" and fuel pump relay is good (swapped in a spare w/no change)
  • All fuses checked.
Dealer thinks the following is possible: door locks have a "switch" that disarms the theft mode, which is an immobilizer. He doesn't know what all it kills, but thinks a door lock switch may be bad. My driver's door does not respond to master switch, but I can key turn it to open. I mean there is no whirring motorized unlock when the key is turned, like the passenger side does. I do not have a keyless remote for it. Theft mode? I do not believe I have Sentry key system for this vehicle (SKIM).

I have a matching part number new PCM on the way from eBay, but dunno if that will help if the "condition" still remains when replaced. I've tried resetting the PCM, but no change.

Any help please? I promise free Alaska glacier air conditioning to anyone who helps solve this issue.
Last edited:
You know that you don't have fuel. But what about spark? It would be an awfully helpful data point to know.

That was in the initial post, no spark. I replaced the coil too (sonufabiyatch to get your fingers behind for those nuts). I have a spark tester and it's shows no spark when cranking, so something is telling the PCM not to send the GO signal to the coil.
Would the PCM talk to an OBD-II scantool if it was dead? The P1694 code says "no data from CCD bus to PCM...." or somesuch?
Thanks, I found that link last night by searching on "CCD Bus". I did test the cluster today using the self-check, and it is good. So there's some issue that is killing or immobilizing the system so it won't start. I was planning to try the procedure in that link this weekend when I have light, but since the cluster IS functional, I think I need to concentrate on the CCD Bus. Besides, a functional cluster still dopesn't get me fuel or spark.
Last edited:
Check for power from the ignition switch to both the fuel pump relay and the ASD relay. Then test for a ground from the PCM to both relays from pin/cavity 51 of the PCM.

Usually when you loose both spark and fuel pump that part of the circuit is suspect. there are a number of grounds in the engine compartment for the late models. Someone posted in a thread pictures with most of the locations. You may have a ground issue due to the wreck and repairs that have been done.
Check for power from the ignition switch to both the fuel pump relay and the ASD relay. ....

Thanks, I know there is power to the ignition mega-fuses in the Power Distribution Center, and we swapped fuel pump relays and the ASD relay with no change. I will search for that thread on grounds.
Oh yea, and both relays (fuel pump and ASD) had power to them on key-ON. I did a search and found some pics of the 4.0 with all the grounds pointed out, but it looked like some were forgotten, such as the battery ground right below the coil. I will dutifully check, clean and tighten them all on Saturday. Also got in my driver's airbag and replacement engine PCM.
Today I got the driver's airbag installed, battery re-installed and then replaced my PCM with a spare I had picked up. I now have all gauges on the cluster react as they should: fuel level, voltage, etc. I checked my OBD-II codes, and still only had the one code, P1694 but this time it CLEARED and stayed cleared. With the good PCM, everything functions again as normal (overhead console, incl), but....

STILL NO FUEL PUMP RUN when I go to key ON. I was not able to check for spark, since I was t-shooting by myself.

Going back to the first post, I have:
  • new PCM, check!
  • new Crankshaft Position Sensor, check!
  • new coil, check!
  • new fuel pump relay, check!
What's next? I tested the fuel pump, but I guess I need to crawl under there again and see if it has power when key goes to ON besides it just running when powered.

I could use some troubleshooting help.
Finally, and frustrated ....

Okay, earlier in this eopisode I had replaced the crankshaft position sensor with no change in "spark". Well, that seems to have changed. Anyway, I also replaced the distributor rotor as it has signs of arcing, and the sensor plate under the distributor, and the distributor cap. Seems to have resolved the "no-spark" issue.

So, on to "no fuel" issue. I jacked up the back and pulled the fuel lines and put a battery to the fuel pump, and got "nada". Nada, no difference in how long I let it run. So, me thinks the fuel pump is the issue. After a lot of grinding (rusted j-bolts) and slicing (rusted hose clamps on the fuel filler/vent lines) I got the tank dropped, and replaced the fuel pump with a jy spare that I had. It spits fuel out nicely if I hook the battery to it now. But .... all those parts: j-bolts, fuel-filler hoses.... NAPA doesn't have 'em, Schucks doesn't have 'em, RockAuto doesn't have 'em....

So I "think" I've got it fixed, but I can't put the gas tank back in until the dealer opens on Monday and I hope he has them....

Oh, and I used and created some new sailor words trying to get the nylon nut off that secures the fuel pump on the 98's. $#@&^%!!!
Okay, put the new fuel pump in and it fired right up! That problem is solved. Now on to fix "the little things", like the RHS of the dash (inlc. oil pressure guage and voltmeter) are dead, and the ABS light is on, plus the "check gauges" light.

It's always something.... BUT IT RUNS!!!!!
Looks like you are making good progress. As far as the dash, I would pull the instrument cluster, clean the connections and try again.