NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Grand Cherokee > ZJ and WJ Grand Cherokees (1993 - 2004)
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

ZJ and WJ Grand Cherokees (1993 - 2004) Technical forum for the classic ZJ and WJ Grand Cherokees.

Reply
 
Thread Tools Display Modes
  #1  
Old March 9th, 2018, 06:42
burntkat burntkat is offline
NAXJA Member #1145
 
Join Date: Apr 2003
Location: Charleston, SC
Posts: 1,164
94 4.0. Hard starts under 40F.

Title says most of it-

Wife's 94 has a hard time starting under 40 degrees F. It won't catch, spins over with authority, but it just sputters, backfires, and coughs till it gets a little heat in the engine.

My fix for now, is the following:

-Turn the switch to run. Wait 10 seconds. (priming the pump and rail)

-Turn switch off. Repeat 2 times.

-Crank. Engine coughs, wants to backfire, will try to run properly if I give it fuel (but again, will backfire). Let it do that for 5 seconds or so, then take my foot off the accelerator. Let it die.

-Repeat the above. Usually twice does the trick, and once I get it to where it will run well at 2000 RPM, if I let off the gas it will idle fine, though a bit high.

I've replaced the fuel pump assembly, as I thought maybe it was an issue with fuel pressure. No difference.

Truck starts and runs perfectly well at anything north of 40 degrees, or if the engine is warm in extremely cold weather (30 degrees, for us, is extremely cold).

I am wondering if maybe it's a fuel injector issue. The injectors have never been cleaned. I do have a set of new 4-hole upgrade injectors I need to swap in.
__________________
-89 S-10: SAS, D44s front/rear. 5.7L V8. 700R4 with 4L60E upgrades. Built in my driveway.
-90 XJ 4.0, AW4, 231J: Clayton's longarms, RE 5.5" coils, hybrid 6" leaf pack, 33/12.50/15" MTs, Rancho 99012s and 99624s, Tera HD SYE, custom sliders, BW flares. Rehabbing with D44s, RE spring packs, RE 4.5" coils, and ACOS.
-94 ZJ: Budget boost, 31s. The wife's DD.
-97 XJ: Son's DD. 4" lift, ACOS, 4" spring pack, Upcountry coils, 31s
Reply With Quote
  #2  
Old March 10th, 2018, 15:43
trippled trippled is offline
NAXJA Member
 
Join Date: Apr 2006
Location: colorado springs, co
Posts: 1,991
Re: 94 4.0. Hard starts under 40F.

Have you checked the coolant temp sensor?
Reply With Quote
  #3  
Old March 10th, 2018, 16:11
techno1154's Avatar
techno1154 techno1154 is offline
NAXJA Member
 
Join Date: Apr 2003
Location: In the islands
Posts: 2,284
Re: 94 4.0. Hard starts under 40F.

The IAC (Intake Air Controller) on the throttle body could be stuck or just lazy.
Throttle body air passage could be blocked with carbon.
Remove, clean and replace.

There are test procedures for the IAC but I have done it.
__________________
Patrick

#594
1996 XJ; 4.0L; AW4; NP231; SYE; D30 and D44; ECTED; 4.10 gears; 30X9.5 -15 BFG/AT/KO; 3" lift; Rusty's LCA; JKS ADJ UCA; Kevins ADJ Track bar; Drawtite Front Receiver; Dual Electric Fans; Dual Battaries.
Reply With Quote
  #4  
Old March 11th, 2018, 15:37
burntkat burntkat is offline
NAXJA Member #1145
 
Join Date: Apr 2003
Location: Charleston, SC
Posts: 1,164
Re: 94 4.0. Hard starts under 40F.

Thanks, gents. I will look into the above!
__________________
-89 S-10: SAS, D44s front/rear. 5.7L V8. 700R4 with 4L60E upgrades. Built in my driveway.
-90 XJ 4.0, AW4, 231J: Clayton's longarms, RE 5.5" coils, hybrid 6" leaf pack, 33/12.50/15" MTs, Rancho 99012s and 99624s, Tera HD SYE, custom sliders, BW flares. Rehabbing with D44s, RE spring packs, RE 4.5" coils, and ACOS.
-94 ZJ: Budget boost, 31s. The wife's DD.
-97 XJ: Son's DD. 4" lift, ACOS, 4" spring pack, Upcountry coils, 31s
Reply With Quote
  #5  
Old March 18th, 2018, 13:24
burntkat burntkat is offline
NAXJA Member #1145
 
Join Date: Apr 2003
Location: Charleston, SC
Posts: 1,164
Re: 94 4.0. Hard starts under 40F.

Got the parts on the way from Amazon (best quality/price I could find) and will install Wednesday evening on arrival. We have a cold snap coming the latter part of the week so I will see what happens then.
Meanwhile, I've just cleaned the TB, added Seafoam to the tank, as well as fogged down the intake with a can of it as well.
__________________
-89 S-10: SAS, D44s front/rear. 5.7L V8. 700R4 with 4L60E upgrades. Built in my driveway.
-90 XJ 4.0, AW4, 231J: Clayton's longarms, RE 5.5" coils, hybrid 6" leaf pack, 33/12.50/15" MTs, Rancho 99012s and 99624s, Tera HD SYE, custom sliders, BW flares. Rehabbing with D44s, RE spring packs, RE 4.5" coils, and ACOS.
-94 ZJ: Budget boost, 31s. The wife's DD.
-97 XJ: Son's DD. 4" lift, ACOS, 4" spring pack, Upcountry coils, 31s

Last edited by burntkat; March 18th, 2018 at 13:26. Reason: Screw Autocorrect. Painfully and with no lube
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
99 4.0 Excessive Cranking - Hard Starts jerms234 OEM Tech Discussion 3 July 20th, 2017 18:36
2000 XJ Starts Really hard chelms27 OEM Tech Discussion 6 July 29th, 2008 17:18
Cold starts=Hard Starts Cherokeekid88 OEM Tech Discussion 8 January 2nd, 2008 22:47
hard starts and stalling Hella-XJ OEM Tech Discussion 3 February 5th, 2007 18:55
Starts hard stalls easy! Gofer OEM Tech Discussion 1 August 10th, 2003 09:19


All times are GMT -7. The time now is 09:18.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014