NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old April 24th, 2005, 12:56
caspergotaz28's Avatar
caspergotaz28 caspergotaz28 is offline
NAXJA Forum User
 
Join Date: Apr 2005
Location: Southeast, TX
Posts: 146
Exclamation '94 XJ Did the gauge swap, temp gauge doesn't move while driving

I swapped in the full gauge cluster from a '96 along with the oil-pressure-sending-unit and the temp-sending-unit. The oil pressure shows fine right around 40. The temp gauge will do a full sweep up when I start it, but the gauge goes nowhere while driving.

I bought the temp sending unit from the stealership. So I know it is a good quality mopar part. I made sure i got the one for 94-96 4.0 with gauges. I checked for corrosion on the plug and didn't see any, scraped the contacts with a x-acto knife. Had a buddy watch the gauge while i wiggled the connector around and still nothing.

One of the main reasons i did the cluster swap was so I could watch the temp. Any help is appreciated.
Reply With Quote
  #2  
Old April 24th, 2005, 16:08
caspergotaz28's Avatar
caspergotaz28 caspergotaz28 is offline
NAXJA Forum User
 
Join Date: Apr 2005
Location: Southeast, TX
Posts: 146
Re: '94 XJ Did the gauge swap, temp gauge doesn't move while driving

Ok I found out what the problem was. The guy at the parts counter gave me the wrong sending unit.

He gave me 56026710, this is the one for idiot lights (same as the one I had)

I need 56027012, this is the one for a full gauge.

Found that info on this thread, post #6
http://www.naxja.org/forum/showthrea...+temper ature
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: 95 XJ Instrument Cluster or just Temp Gauge fishbum Wanted: Private Party Only 0 August 4th, 2004 07:40
Temp gauge way off? brtb OEM Tech Discussion 13 July 14th, 2004 09:00
Temp gauge, part 2 brtb OEM Tech Discussion 4 July 14th, 2004 08:31
Temp Gauge testing? Raider_Dave OEM Tech Discussion 4 June 7th, 2004 21:29
Gas Gauge one 1999 XJ Manuel OEM Tech Discussion 4 April 15th, 2003 17:15


All times are GMT -7. The time now is 19:04.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014