• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

Rough idle & CEL with no codes?


NAXJA Forum User
D/FW Metromess
Long story short, just put in a reman AW4, and a week later the CEL came on first thing in the morning. Was running fine, tried to pull codes with my Amazon special OBDII scanner, no codes found, tried to erase them anyway, CEL stayed on. Fast forward a couple days, and idle gets really rough and sputtery when I'm in drive at a stoplight or backing up in my driveway (slight incline) but not in park or neutral. CEL stayed on for almost a week, then didn't come on this morning, but still idles rough in drive, etc.

I know to check the TPS & CPS, Mopar only, etc. My question is, is there something else I should be checking? Thanks!

99 XJ, 278k, 70k on reman 4.0 engine, newly installed reman AW4, NP242.

I would start with a good scanner to find out!
I'm somewhat dealing with the same thing. In my case engine was replaced 11 months ago. No codes and feels like a miss. Following along to see if any of your responses might shed light on mine.
I'm somewhat dealing with the same thing. In my case engine was replaced 11 months ago. No codes and feels like a miss. Following along to see if any of your responses might shed light on mine.

What year?
On my 2k it was failing wire to my injectors. My advice would be to thoroughly inspect all the wiring. Can you get real time data so you can see issues when it happens. Misfires can be caused by sensors that dont register a code to the ecu because they still read "tolerable" or too short duration.
Okay, here we go...

'99 XJ, 4.0, Auto, NP242, 280K miles, big battery & ground cables, but mostly stock with a mild lift & 31s.

Reman AW4 a couple months ago, which by the end involved a new battery as well, after a weird grounding issue killed the Red Top I had before.

Engine is a reman 4.0 installed 4 years ago, and now with about 71K on it.

Started with a rough idle a while ago, CEL but no codes, tried with my brother-in-law's much more powerful scanner, and it didn't come up with anything either. Rough idle seemed to work itself out after a couple weeks, then the CEL went away for a few days, then back, then gone, lather, rinse, repeat.

Replaced the TPS & crank sensor with MOPAR parts, cleaned & checked connections, checked grounds, O2 sensors replaced (Bosch) just because.

CEL finally went away beginning of last week, then Friday night battery was dead when I was trying to leave work. Starting it up with my little jump box took forever, because it would run a few seconds then quit. Thought it was the SKIM/Sentry system, because that's been an intermittent issue previously, but unlike those instances, if I kept giving it gas, it would keep running. As soon as I took my foot off though, it would quit again. Finally managed to get it started and drive away, and it still kept trying to die on me anytime I came to a stop. By the time I made it the 10 miles home, it was running a little better, and I could see the voltmeter was slowly climbing back toward 14, whereas at first it was around 11.5-12.

Got in the driveway & got to work again. Quickly found another bad connection, this time the positive lead for the headlight relay upgrade I did a few years ago. Got it situated, pulled the battery to charge, and left it overnight. Next day, I pulled the battery tray to better inspect wiring. Found one of my big cables had been routed under the battery tray at some point (it wasn't like that when I replaced them) and it's got a pretty significant crimp in the cable now, but no exposed wire. Rerouted it, checked all my other connections again, got under the dash to check what connections I could see there too, made sure the SKIM/Sentry wasn't loose or disconnecting either just in case. Popped the battery back in, started up immediately.

Took it to O'reilly's and asked them to check the battery & alternator, and both came back fine. All this week it's been starting just fine, but still idles rough sometimes, CEL is intermittently back (still no codes...) and when coming to a stop the RPMs sometimes drop like it's about to stall, then it pops back to just over 1000 for a moment and levels off around 700-750.

Then this morning, fast clicks and no crank. Jump box worked, but died if I took my foot off the gas. Got it running enough for me to make it to work after about 5 minutes, and it died twice on the way, both times after coming to a stop & putting it in neutral. Realized it wouldn't die but would drop the RPMs & pop back if I kept it in drive, unlike years ago when a bad alternator kept stalling me out if I wasn't in neutral.

Holy crap, y'all. Where do I look next?

No Bosch O2 sensors, only use NTK. Many 4x4 Forum threads detail the Jeep 4.0 and Bosch O2 sensors not playing well together.

The stalling, rough start, clicking, no idle/poor idle symptoms point to low voltage. Suspect lack of charging or poor quality wire connections.

Were the alternator and battery Load Tested in the shop, or tested in the vehicle with a handheld test device ? Hand held testers often pass marginal components that would fail a proper Load Test.

Once the starting and charging have proved out as good, the Idle Air Controller should be cleaned and checked.

Perform routine maintenance of the start and charge systems. Remove, clean, and firmly reconnect all the wires and cables to the battery, starter, and alternator. Look for corroded or damaged cables or connectors and replace as needed. Copper wires should be copper color, not black or green. Battery terminals and battery wire connectors should bright silver, not dull gray/black and corroded. Do the same for the grounding wires from the starter to engine block, the ground wires at the coil, and the ground wires from the battery and engine to the Jeep's frame/body. You must remove, wire brush, and clean until shiny the cable/wire ends and whatever they bolt onto.

Jeeps do not tolerate low voltage, bad wire connections, or poor grounds.

Place your DVOM (Digital Volt Ohm Multi-Meter) on the 20 volt scale. First check battery voltage by placing your multi-meter's positive lead on the battery's positive post ( the actual post, not the clamp ) and the negative lead on the negative post. You need a minimum of 12 volts to continue testing. Next, leave your meter connected and take a reading while the engine is cranking. Record this voltage reading. Now connect your positive lead to the battery terminal stud on the starter and the negative lead to the starter housing. Again, crank the engine and record the voltage reading. If the voltage reading at the starter is not within 1 volt of battery voltage then you have excessive voltage drop in the starter circuit.

Typical voltage drop maximums:
• starter circuit (including starter solenoid) = 0.60 volt
• battery post to battery terminal end = zero volts
• battery main cable (measured end to end) 0.20 volt
• starter solenoid = 0.20 volt
• battery negative post to alternator metal frame = 0.20 volt
• negative main cable to engine block = 0.20 volt
• negative battery post to starter metal frame = 0.30
• battery positive post to alternator b+stud = 0.5 volt with maximum charging load applied (all accessories turned on)
Last edited:
Alright, here's the update:

Pulled the battery & alternator and had them both bench tested. Battery is lower than it was on CCA, but otherwise fine. Alternator is fine. Battery issue is likely the result of the repeated draining lately. Ran through all the voltage checks and nothing seemed out of spec that I could tell. Tried to do a parasitic draw test and really quickly saw 6 ma coming from somewhere, but couldn't isolate it. At that point I bit the bullet and called my local shop.

They've isolated it to fuse 22 in the PDC, which controls fuel pump etc, and when they pull the fuse the draw goes up to 8.4 ma, which baffles me. Shouldn't pulling a fuse lower or eliminate a parasitic draw?

They've already checked the fuel pump, PDC, grounds everywhere under the hood, and they're still searching... So far, nothing has been identified as the source. Any suggestions on where else I/they should look? Thanks!

Going through this myself. I have about 280K on my 2000 XJ. Been a rough XJ year for me. I have been building an mini-stroker over the past few years. Due to #6 piston loosing its skirt, I had to get bold and take out the combustion chambers out to 59ccs. Anyways, I was doing OK with the break in. Around 500 miles the CEL started to flash. I did have a slight miss the past few years. I had changed over to a Doug Throley header and the down pipe I had from it on my '98 XJ. Then I had the down pipe done with a 'V' band. Leaks reduced, engine not running right, konks out when Idling. Muffler hot. So, I need to replace the muffler and or Cat. Also, the 'fake' distributor wobbled a bit. I replaced it with the one off a 2001 XJ I have. Its getting an LS. I also replaced the coil rail with a Viper coil. Yeah, finally. I had a bracket made, as I'm using a '99 head. I reused some Magnecor XJ wires. I did cut some Taylor wires, but I questioned if I nicked the core wire when cutting the sheath.
I also need to check the wires from the ECM to the coil. Also, probably the injector wires.

Also, I did try and check codes with lower grade Antron. No codes. I had it checked by someone I use for Jeep work. #6 missfire. I rechecked with the Antron later, and a coil failure.
Alright, probably (hopefully) the last update for a bit.

Wiring harness has some damage under the hood that explained some of the parasitic draw, but still didn't account for everything. A full, thorough inspection revealed a perfect combination of old wiring beginning to crack & break and rodents of some kind (I hope squirrels...) chewing away at the harness above the transmission & behind the engine block. CEL wasn't bringing up any codes because the intermittent mixed signals weren't actually throwing any sensors, just a "crap ain't right" general sitrep. Of course, MOPAR doesn't make replacement harnesses anymore. Supposedly no one really does? Shop says they found an aftermarket one they can use to cut & splice the needed repairs, but it's still going to take a few days for the harness to come in and another day or so to finish everything. Oh, and nearly $1500 in parts, labor, & diagnostics...

Ouch. Merry Christmas kids, I got you a functioning vehicle.