NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Comanche MJ (1985 - 1992)
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Jeep Comanche MJ (1985 - 1992) Jeep's Cherokee-based compact pickup technical forum.

Reply
 
Thread Tools Display Modes
  #1  
Old November 1st, 2019, 13:46
pyrohildy pyrohildy is offline
NAXJA Forum User
 
Join Date: Nov 2019
Location: Yorba Linda ca
Posts: 1
Comanche starts, runs, sputters out

It'll start, and it'll run for a bit, but it dies shortly after firing up, whether left to idle or giving it throttle.

Anybody know why an '89 4cy would be doing that? It has fuel, new fuel pump, and it ran fine for better than a half hour a week ago, and good for a couple minutes at a time two days ago, and nothing this morning.
Reply With Quote
  #2  
Old November 1st, 2019, 15:23
smokeyyank's Avatar
smokeyyank smokeyyank is offline
Jeepoholic
 
Join Date: Jul 2014
Location: Gypsum, Crawlarado
Posts: 937
Re: Comanche starts, runs, sputters out

www.cruiser54.com

is a good starting point.

If you haven't yet get on comancheclub
__________________
88 MJ, 4.0, 4wd, 3 pedals, Shortbed.
Mods; ACOS, quick discos, HD tie rod and a bitchin air fresher
04 WJ, 4.7HO
Mods; 3" IRO lift, ADDCO rear sway bar, 4.7HO with bored fastman TB, AFE intake and Superchip tuner, 32s, lunchbox rear 242HD, 3" Kolak exhaust
Reply With Quote
  #3  
Old November 1st, 2019, 16:03
00rottweiler00 00rottweiler00 is offline
NAXJA Forum User
 
Join Date: Oct 2019
Location: Delaware county, Pennsylvania
Posts: 6
Comanche starts, runs, sputters out

I dont have any experience with the 4 cylinder jeeps, do the 4 cylinders have a CPS like the i6s do? If so, that sounds exactly like a failed crank position sensor to me and probably worth checking out

Sent from my SM-N960U using Tapatalk
Reply With Quote
  #4  
Old December 3rd, 2019, 22:44
tm8chris tm8chris is offline
NAXJA Forum User
 
Join Date: Apr 2014
Location: GA
Posts: 51
Re: Comanche starts, runs, sputters out

Check the crank position sensor, TPS and CTS.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 XJ Barely Starts, Sputters and Backfires at 2000 RPMS HunterRivett OEM Tech Discussion 2 October 27th, 2014 06:11
starts, sputters, dies... tazam80 OEM Tech Discussion 3 October 8th, 2013 04:49
Starts fine, drives fine, bucks, sputters and dies randomly? tayman OEM Tech Discussion 94 July 19th, 2011 13:52
starts and runs - but then does not start after RTFM OEM Tech Discussion 7 August 5th, 2008 07:35
Starts, Idles, Sputters, Dies TN William OEM Tech Discussion 3 April 21st, 2003 07:28


All times are GMT -7. The time now is 19:35.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014