• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

I cant pull my axle shafts!!


NAXJA Forum User
Well I am attempting to put a locker in the D30 so I am trying to pull my axle shafts as the writeup says. I got the calipers off and I got the three 1/2 bolts off the back near the rotor, from the writeup it says I should be able to pull the out but NOPE!! I have some pics so is there anything I missed.





Put the 3 hub bolts back in part way and lightly tap them with a hammer to break the hubs loose.
It is more than likely just rusty build up where the hub seats at. sometimes they can be a real beatch. you can make a make shift slide hammer with some chain. get a chain that the links will fit over you lug, smug them down on with a couple lug nuts and whip away.
If the above doesn't work, I would suggest a winch.

That gets them every time.

Remember, safety first!

Do as Johnny Said. I had the same problem. They would not budge with anything else I did. But when I put the bolts back in, a little bit of tapping worked like magic.
you might want to take off the big nut off the axle first ..... may be easier to take it off while the axle is in the jeep.... cant really tell from the pic if it is off or not
Ill give the ol' tap tap taparoo a try tomorrow. I was yanking as hard as i could, I had the car lights on facing me so I could see.
was worried there for a second:D. dont need to take off the big nut, all you have to do is slid the shafts out a tad
If you take off that big nut and pull with a slide hammer or winch you mind as well buy some new hubs since that axle stub is very key in the structure of the hub assembly.

get old hub bolts to beat on
There is no reason to take the big nut off. You'll just cause yourself grief trying to retorque it.

xjrrrdx said:
now what about the c-clips, everywhere i read didnt mention c-clips needing to be removed.

Only the disco axles have a C-clip on the passenger side.
Well I did the bolt and tap method and it worked like a charm...Thanks guys!!! The rest of the install went like butter, pulled the carrier, assembled the locker and popped it in. When I started her up and rolled forward I heard a real loud "CLUNK" I rolled forward more and it was gone, now when I turn I hear a slight click, which I know I am supposed to get. Now is there anyway to make sure that I can lock without going out to the trail???
leave your sway bars connected and go flex on something usually if your open at both ends you will only be able to go as far as you have traction but with a locker you will be able to roll your rig right on it's side :laugh3: no seriously if you flex it up with your sway bars connected and one of your front and one of your rear tires is off the ground and you can still move up the object, it is working. also you can go on loose sand and turn sharp with a little gas you will see that one of your front tires will scrub as it makes the turn.
should come with instructions how to tell. dont want to dig mine out, something along the lines of jacking it up and spinning one tire one way and holding the other...its out there somewhere, should be hard to find
let's see....put the jeep on jackstands so the wheels are in the air.Put a couple floor jacks under there too for safety.

put jeep in 4x4. grab a front tire.your choice. turn it in a direction,again your choice.

if its locked,both tires shouls turn the same direction .If not,it's not locked.

Or,take it out and run it on some loose dirt/mud. that's more fun.

I think your locker is working. :)
Well I drove to work tonight and the locker is un-noticable on straight aways. However on turns I hear the slight clicking but the one thing I noticed was like a VERY VERY slight clicking in the steering wheel, it goes along with the clicking sound of the locker.
it's called "telegraphing" since the steering wheel is connected to the front axle anything the front axle "feels" the wheel does as well. Don't worry about it.