• Welcome to the new NAXJA Forum! If your password does not work, please use "Forgot your password?" link on the log-in page. Please feel free to reach out to [email protected] if we can provide any assistance.

I got a performance boost...

MELKORsXJ

NAXJA Forum User
Location
Chattanooga, TN
So... Tyler and i have had a crazy idea/modification for the Willys.

some people know what this is about.... :dunno:

anywho, after some internet researching, some time over at RSOR, and of course some money, we decided to give the 3B a little performance "boost" :)

pictures say alot, so i'll post them up...


BEFORE:

l_608a9ab93a4149d08f40893d185657d3.jpg


l_98827ef5095840c488b46d7ea31a96a6.jpg


l_47909a689c9142beac6806e46b17d582.jpg


l_7e51bef0e2014f0ba87be99a11a75830.jpg


l_4285ef4c423441f684cd2823117ffa28.jpg


l_c921d62c84674282ac178cebad94b854.jpg
 
Last edited:
Re: i got a performance boost...

PARTS:

l_0372893896e34a14ba1671b08d4a1a0a.jpg


l_c31ac22dabda4c319fda01c99e5192c5.jpg


l_eb8a036a0bbb412eb1346ed7262f8458.jpg


l_19ed2f21f5d844f6b8942de5486d1983.jpg


l_5e9faaf8a3144f27a2c92488c26ae197.jpg



...one thing that has needed some attention was my passenger side exhaust tube. due to not getting around to trimming my U-bolts, and having lots of flex, they kinda crushed the exhaust, and might be the reason they Line X caught fire last trip, since the exhaust couldn't breath and got too hot! ...that might be why it ran rought at times? :dunno:

l_f9b4514c184a4b4b896949a2a277eac8.jpg


l_d603b14032c041cd8919c0756e455143.jpg


l_b7747727f88b4b608b10e94b601dd598.jpg
 
Re: i got a performance boost...

...onto the fab work over at RSOR:

l_d9c6efd8106e45d5a1431583e225fa34.jpg


l_633268d252b44e9d92dab4ae7a06d7b5.jpg


l_77921d73676a415ea7ce48a6c56aa072.jpg


l_a3dd2511b90b4ba8aa990b45d58008ef.jpg


l_5f38b1b2c2e74c47a9c0c87832fbf4af.jpg


l_f4a9341628134f0681452fc913d10c9e.jpg


l_c370a81a66e04fababce1f8389bc8d78.jpg
 
Re: i got a performance boost...

We also had to make some slight adjustments to the 3B hood, after mother nature added its own touch to my jeep...

l_c7f7a944a1994495af5c4b888c015d30.jpg


l_0061a7d798974b5c8f736dab6e563fba.jpg



...and we added an extra guage :)

l_14bd7d86c4e7480d98ed8cdbd347a541.jpg


.
.
.

first setup, with Blow Off Valve (din't work, made flange, and sent "extra boost" back into the air filter side, as it came factory)

l_aa66e041747b461db1fcd3f19a544759.jpg


.
.
.




...AFTER:

l_1d0988dbe79342399b4bc850280abf69.jpg


l_0caad243a7344c458628decb51035ad1.jpg


l_99976a9a5ca14fd4ae0c742d43a133ad.jpg


l_d8d3fcbbd83f424bbbe5fbec2ff3aa21.jpg


l_b44d62c60779474da9c3aeb8b35a59c5.jpg










and what fun would this thread be without a video right? :dunno:

http://www.youtube.com/watch?v=NLEMQcN0X0I#watch-main-area



i might also add, that i got a chip burnt for the jeep, so it recognizes boost from tbichips.com
and our setup is sort of based off of the kits offered on tbisuperchargers.com


FINAL VERDICT?

as of right now, the jeep runs fine... until it gets above 3500rpm under load, and builds ~5psi of boost at that point. past 3500 it starts to run a little rough, due to a lack of fuel. We're gonna swap in some 350 injectors (55lb vs 40lb) and then go from there, as that's not too dificult to try...

there is definetly a noticable increase in "pep" with a blip of the throttle... i just can't wait to get into the higher RPMs!!!


wanna see it in person?
see you guys at windrock on the 20th :)
 
Awsome Dan. That should kick it in the seat of the pants.
 
Injection is nice, but I would rather be Blown!
You gonna like that.
 
it sounds like a big mean dustbuster under your hood ;) looks good guys wish i coulda helped with it but i had to work this weekend, any idea how its going to react to operating temps under the hood? theres not really any more room to stick an intercooler....
 
you need a sticker on there now to warn people:
71419495v5_480x480_Front.jpg
 
Well done gentlemen! Very clean install, take a sanding wheel to the "3.8" logo on the charger. Sounds wicked!:greensmok
 
Thanks guys!!!

Swapped in 350 injectors and it helped a good bit, but still not perfect.
We took a driveby video, but it messed up and cut out the whole middle of the video... so its not worth putting up I don't think...

...might try a better ignition setup, to ignite the air and fuel better.
 
Why don't you talk to the guy at TBI chips I think he could give you some help in it Also put a walbro 255 fuel pump in it that might help .

Other then that it looks like aclean set up. you now at the hard part of dialing it in
 
i was gonna shoot him an email when i got some time... (busy packing for daytona... spring break this week)

...here's the video of the driveby with the bigger injectors

http://www.youtube.com/watch?v=LReRRfF4pDU

stinks that it messed up :(
 
Back
Top