NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Chapters > NorthWest Chapter
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

NorthWest Chapter Discussion of Chapter issues. Please keep Tech Topics on the Tech Forums.

Reply
 
Thread Tools Display Modes
  #1  
Old August 14th, 2007, 21:59
cleatus92's Avatar
cleatus92 cleatus92 is offline
NAXJA Forum User
 
Join Date: Aug 2006
Location: spokane
Posts: 130
Unhappy HELP I've screwed up my Jeep

So I was fininshing up a lengthy repair job on my jeep, got it all back together, and it started leaking at the rear tranny line coupling with the quick clips. By the way I love my Y-link but what a bitch to work around!!
Anyway I pulled the coupling And removed the tranny line and found a small peice of the previous broken quik clip in there. So I removed it and began to replace the coupling back into the tranny. This is where my fun began, I got a couple of threads in by hand and figured sweet its started lets tighten her down. Right? Wrong, I somehow in my apparent hastiness to go out and run my new 33's I cross threaded that steel coupling into the aluminum tranny housing. Now I have no reachable threads. Anyone ever screw this up besides me?? If so any fixes possible without pulling the tranny again? I'm thinking tapping it with a pipe tap and a threaded bung. Is there a longer steel coupling out there that would reach the threads. I really don't want to pull the tranny again!!!

Anyhow thanks, and any Info or HELP is appreciated.
Cleatus92
Reply With Quote
  #2  
Old August 14th, 2007, 22:05
CanMan's Avatar
CanMan CanMan is offline
NAXJA Forum User
 
Join Date: Oct 2005
Location: Lake Tapps, WA
Posts: 8,460
Re: HELP I've screwed up my Jeep

Thats no good Trevor.

I would try to tap it first, thread in a tube adapter, and run a rubber hose between the two.

If that doesn't work, might have to pull it again, and have a aluminum bung welded on the outside. Unless it can be reached with the belly pan on.
Reply With Quote
  #3  
Old August 14th, 2007, 22:36
Boxil's Avatar
Boxil Boxil is offline
NAXJA Forum User
 
Join Date: Mar 2007
Location: Tacoma, Wa
Posts: 234
Re: HELP I've screwed up my Jeep

Trevor that sucks man. i've got pipe taps but sorry that none of them would fit your situation. all i've got are for our big pipe. 1.5" and bigger. hope it works out for ya.
Reply With Quote
  #4  
Old August 14th, 2007, 22:36
mud1059's Avatar
mud1059 mud1059 is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: Graham/Kapowsin, WA
Posts: 1,343
Re: HELP I've screwed up my Jeep

helicoil. I think it's how it's spelled. I had to use it on a head bolt on my first 22r (aluminum block) rebuild. They sell it at NAPA I know and most others I'd figure.
Reply With Quote
  #5  
Old August 16th, 2007, 12:02
Boxil's Avatar
Boxil Boxil is offline
NAXJA Forum User
 
Join Date: Mar 2007
Location: Tacoma, Wa
Posts: 234
Re: HELP I've screwed up my Jeep

so Trevor did ya get it fixed? whats the update?
Reply With Quote
  #6  
Old August 16th, 2007, 14:00
cleatus92's Avatar
cleatus92 cleatus92 is offline
NAXJA Forum User
 
Join Date: Aug 2006
Location: spokane
Posts: 130
Re: HELP I've screwed up my Jeep

Not fixed yet. Working out a couple different options tonite. Looks like I've got to pull the Y-link.
Reply With Quote
  #7  
Old August 16th, 2007, 22:53
cleatus92's Avatar
cleatus92 cleatus92 is offline
NAXJA Forum User
 
Join Date: Aug 2006
Location: spokane
Posts: 130
Re: HELP I've screwed up my Jeep

Well I got it fixed!!! With the help of Napa Guy AKA Dad. He drilled out a 14mm bolt and we tapped it to accept a hose fitting. We then cut down the drilled out bolt to .9110in, teflon sealed the hose fitting into the bolt, threw on a o-ring and caefully tightened it down. we also replaced a section of the metal trans line with rubber transmission oil cooler line and hose clamps. Thus far no leaks and works like a champ. Oh and finally got to drive on my new Trxus 33's. Awesome. I'll be wheeling tommorow evening and then Naches on labor day weekend.
Cleatus92
Trevor
Reply With Quote
  #8  
Old August 16th, 2007, 23:00
CanMan's Avatar
CanMan CanMan is offline
NAXJA Forum User
 
Join Date: Oct 2005
Location: Lake Tapps, WA
Posts: 8,460
Re: HELP I've screwed up my Jeep

Glad to hear you got it fixed, now you can wheel again.
Reply With Quote
  #9  
Old June 8th, 2019, 22:37
SmokeyTheRedXJ SmokeyTheRedXJ is offline
NAXJA Forum User
 
Join Date: Aug 2016
Location: Fontana CA
Posts: 10
Re: HELP I've screwed up my Jeep

Know this is an old thread but guess what just did it today I broke the top the top left portion off my port could you post some pictures
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Am i screwed?????? Jeep9717 Modified Tech Discussion 27 June 27th, 2007 20:13
I screwed up and need some help (NSS) white99z OEM Tech Discussion 4 May 20th, 2007 21:11
well i think im screwed xDUMPTRUCKx OEM Tech Discussion 16 May 21st, 2005 15:28
am i getting screwed? madcrazy_lp OEM Tech Discussion 6 April 16th, 2005 09:56


All times are GMT -7. The time now is 23:48.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014