NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Chapters > NorthWest Chapter
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

NorthWest Chapter Discussion of Chapter issues. Please keep Tech Topics on the Tech Forums.

Reply
 
Thread Tools Display Modes
  #1  
Old April 18th, 2013, 15:32
NW-ZJ-SCOTT's Avatar
NW-ZJ-SCOTT NW-ZJ-SCOTT is offline
NAXJA Member
 
Join Date: May 2008
Location: Central Texas
Posts: 9,707
90' XJ build..

I've never had a build thread.. And regret it.. Would be nice to be able to look back and remember when I did this or that..

Picked this jeep up in september of 2012.. $700 brought her home..
It has the typical renix problems, Leaking rear seal, Everything caked in 1/2" of Black Crisco thick grease.. no front end in 4wd.. Leaking Coolant bottle etc etc..



Started with swapping on some 30" Tires and Rubicon 16" wheels, Blacked out tail lights.. aswell as a Stereo and speakers..



A few days later I tackled the Rear main seal/Oil pan gasket leak..


While I was in there, I painted the Pan and fixed the front axle disconnect problem.. Aswell as installing the Yellow ford 19lb injectors (iirc.. they are ford?)


After putting it all together, I discovered an old problem i had forgotten about..
Renix oil filters are different



after fixing that and picking up the correct filter, I drove it a few times.. the Injectors really helped on throttle response!!


I took it out on a little adventure.. IIRC it was the Mt.Hood Lake tour, with Gold_Cobra, a Member formally known as Nightfoam, and a really cool guy in a Kia..




This trip ended in a slight disaster.. I discovered the 2 other O-rings in the fuel system i had neglected to swap out.. and of course, I developed a Fuel leak at the regulator.. A kickass dude in a Subaru, rushed too us with O-rings and Gorilla Tape.. we were able to patch up the leak and I made my way safely back to town..



Shortly after fixing this issue, I took the XJ to work one morning, Only to get halfway and have the transmission completely stop shifting out of 1st gear.. so I parked it..

and it sat for 4 months

One day last month, I swapped in a new TPS, and gave it a jump start.. for some reason my brand new Excide Orbital XCD battery refused to hold a charge



after firing it up and cleaning out some of the winter moisture issues that arose from it sitting with a leaky wing window.. I Put it on insurance and finally got it Tagged and titled




I'll be updating as i go!
__________________
ZJ, Atlas 4 speed
Reply With Quote
  #2  
Old April 18th, 2013, 16:41
BPB BPB is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Battle Ground, Washington
Posts: 2,402
Re: 90' XJ build..

Looks good Scott. What are your future plans?
Reply With Quote
  #3  
Old April 18th, 2013, 21:12
NW-ZJ-SCOTT's Avatar
NW-ZJ-SCOTT NW-ZJ-SCOTT is offline
NAXJA Member
 
Join Date: May 2008
Location: Central Texas
Posts: 9,707
Re: 90' XJ build..

I've been questioning the oil pressure with this jeep since after i did the rear main seal.... So i picked up a Decent cheap Pressure gauge


Sure enough it runs a little on the low side.. but everything I research says that's typical of a Renix 4.0 and it's within factory spec.



Replacing the Oil pump is on my list as a priority, but with what i have researched, I am still in the Safe zone and have some time


I picked up a cheap XJ to part out and stock up on spare/replacement parts


Another problem I had been having was the Charging system, Just having my fan on was enough to drop the voltage into the red, so it was time to start the Basic's.. First off! Blue top! the Excide Orbital had Failed for a second time.. Still being within warranty, I got a refund and bought a Blue top!

Then it was Cables!
I Put a new large Ground strap from Block-to-firewall aswell as replaced the Battery-to-block ground, and added 2 Extra Grounds, Battery-to-fender & a second Block-to-firewall.. And also replaced the Positive wires aswell, and added a secondary Alternator positive, that goes straight to the Battery..

Everything seemed better.. but i still wasnt "Golden" So with a little Arm-twisting from a fellow Parts-hoarder.. I picked up a 110amp High-output Renix Alternator..


Monday night I started a phase of Maintenance.. new Waterpump/thermostat/Clutch fan/Open cooling systems radiator & bottle/Idler pulley..



Unfortunetly, the waterpump that I have held onto for 80 thousand years.. does not work for my application.. and running low on funds, I regretfully had to Delay the waterpump replacement, Irritating for sure.

I also picked up a RADesigns Rail II shifter, Used from a Fellow member (98CherokeeSport..aka Brandon) and Ordered a Set of Brown dog Motor mounts! (Awesome Naxja Discount!)


I am slowly moseing the front end back together.. While i wait for the Motor mounts to arrive.. I'll probably Pick up a waterpump friday aswell..


Quote:
Originally Posted by BPB View Post
Looks good Scott. What are your future plans?
As of right now, I have a Complete 3" lift put together, Shocks/arms/trackbar/springs/leafs/shackles/brake lines/Bumpstops/T-case drop.... I Plan to pick up a set of 31" tires and run the basic 3" lift & 31's for now..

I have factory hooks to install up front, and a Tank skid/rock sliders to install, I plan to rock it like that for a couple months.. The idea is a good solid DD/WW rig. Honestly, I'm not "In love" with this XJ.. If that changes.. Then We'll see what happens over the summer.... At this time, the "Plan" is find another 5.9/Late model/YJ to put my Claytons/Axles/tires under.. And slap a Grand krawlers sticker on it and sell it all for $18k
__________________
ZJ, Atlas 4 speed

Last edited by NW-ZJ-SCOTT; April 18th, 2013 at 21:24.
Reply With Quote
  #4  
Old April 19th, 2013, 10:17
kenny811 kenny811 is offline
NAXJA Forum User
 
Join Date: Apr 2007
Location: Damascus, OR
Posts: 1,460
Re: 90' XJ build..

On my RENIX, the oil pressure would be in the mid 60's after about 1100RPM's. It would be down about 10 at idle. From everything I read its normal, so I think you will be ok there.
Reply With Quote
  #5  
Old April 19th, 2013, 10:48
BPB BPB is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Battle Ground, Washington
Posts: 2,402
Re: 90' XJ build..

my oil pressure is super high in mine
Reply With Quote
  #6  
Old April 19th, 2013, 11:53
BoringDave BoringDave is offline
NAXJA Forum User
 
Join Date: Oct 2008
Location: Boring
Posts: 2,748
90' XJ build..

Rule of thumb 10psi for every 1000rpm's
Reply With Quote
  #7  
Old April 19th, 2013, 14:34
Red91Laredo's Avatar
Red91Laredo Red91Laredo is offline
NAXJA Forum User
 
Join Date: Jun 2012
Location: Portland, Oregon
Posts: 287
Re: 90' XJ build..

My old Renix had similar oil pressure, about 10-15 at idle and 50-60 above 1500 RPM, IIRC. It also had the same awful RMS leak, non working vacuum disconnect, and closed cooling system issues. Ran like a top though.

Anyway, nice looking XJ. You don't see too many black older models around.

Last edited by Red91Laredo; April 19th, 2013 at 14:50.
Reply With Quote
  #8  
Old April 20th, 2013, 22:58
NW-ZJ-SCOTT's Avatar
NW-ZJ-SCOTT NW-ZJ-SCOTT is offline
NAXJA Member
 
Join Date: May 2008
Location: Central Texas
Posts: 9,707
Re: 90' XJ build..

well.. It's been a week, and my motor mounts havnt even been "Made" yet.. So I'll just install them at a later time..

I got everything buttoned up, and Redjeep2.0 showed up.. He helped me eliminate some of the Renix garbage.. a whole pile of it!




Converting to the Open cooling system is relatively easy, Pick up a 92+ Open radiator, and an open cooling system bottle, and about 6 feet of 7/8" ID Radiator hose..

..Eliminate the Closed bottle/tray.. Pull the two heater core hoses, as well as the smaller thermostat housing hose, and The Smaller waterpump hose.. *You should also have a "Heater control valve" inline somewhere in all that.. It's vacuum actuated*.. Mine had been eliminated..

Run your new hose Bottom Heater core port, to Smaller waterpump pipe.

then run a hose from your thermostat to the top port..

Mount your new Overflow bottle higher then the radiator by at least 50% (iirc?)
Run a small 1/4" ID hose from the Nipple right below the radiator cap, to the Overflow bottle..

Done

I plan to add a Heater valve next trip to the Junkyard.. for now I (or..should i say Nick) Ziptied the hoses together with the Vacuum line and have a spliced spot to add the Valve later on..

While in there, Nick cleaned up a bunch of the Renix mess.. Thanks nick!


__________________
ZJ, Atlas 4 speed
Reply With Quote
  #9  
Old April 20th, 2013, 23:55
SPECFab SPECFab is offline
NAXJA Forum User
 
Join Date: Oct 2012
Location: Kalama wa
Posts: 622
Re: 90' XJ build..

I just bought a heater valve and it was in stock at oriley for $21 its not worth getting from the wrecking yard
Reply With Quote
  #10  
Old April 21st, 2013, 03:37
BPB BPB is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Battle Ground, Washington
Posts: 2,402
90' XJ build..

My renix has slowly lost most of its renixness over the years I think I'm down to two or three vacuum lines and I still have the closed cooling system. I should have just done what you did six years ago.
Reply With Quote
  #11  
Old April 22nd, 2013, 16:37
NW-ZJ-SCOTT's Avatar
NW-ZJ-SCOTT NW-ZJ-SCOTT is offline
NAXJA Member
 
Join Date: May 2008
Location: Central Texas
Posts: 9,707
Re: 90' XJ build..

I've been holding on to a few parts from my OD Green XJ.. One of the parts I kept was the CCV vacuum setup because it was relatively new when I parted that XJ out..

Found a slight problem, that maybe could relate to my Poor idle?


Went out to my Spare motors, and found just what i needed


Tuh duh!!



Also found a New Waterpump in my Long-term spare parts pile in my Basement decided to get that done today, I think the other one i have held on to is for a 4.0 ZJ? Idk.. its a different Pulley surface.. but still Reverse rotation?







Now i need to pick up a new hose to connect the radiator and Overflow tank.. aswell as a new Valve cover gasket/front CCV valve cover Tube..

__________________
ZJ, Atlas 4 speed
Reply With Quote
  #12  
Old April 25th, 2013, 13:18
NW-ZJ-SCOTT's Avatar
NW-ZJ-SCOTT NW-ZJ-SCOTT is offline
NAXJA Member
 
Join Date: May 2008
Location: Central Texas
Posts: 9,707
Re: 90' XJ build..

Finally got around to putting the front tow hooks in



Also decided that turning 15 feet of 2x6 into sliders. Was better then rocker cutouts for this rig. Already had the steel.
They look goofy with stock height on 30s. But that will change soon enough!



Thanks CJ @bdc fab, for the help!
__________________
ZJ, Atlas 4 speed
Reply With Quote
  #13  
Old April 25th, 2013, 15:31
BoringDave BoringDave is offline
NAXJA Forum User
 
Join Date: Oct 2008
Location: Boring
Posts: 2,748
90' XJ build..

Ill be home Sunday after noon and you can come over to get the tires.
Reply With Quote
  #14  
Old April 26th, 2013, 11:38
Red91Laredo's Avatar
Red91Laredo Red91Laredo is offline
NAXJA Forum User
 
Join Date: Jun 2012
Location: Portland, Oregon
Posts: 287
Re: 90' XJ build..

Looking good. I like the idea of 2x6 made into sliders. I need to get in touch with BDC soon and get myself a set...
Reply With Quote
  #15  
Old April 27th, 2013, 20:13
NW-ZJ-SCOTT's Avatar
NW-ZJ-SCOTT NW-ZJ-SCOTT is offline
NAXJA Member
 
Join Date: May 2008
Location: Central Texas
Posts: 9,707
Re: 90' XJ build..

So. Added some V8 Zj coils/second isolator. And a set of 1.5" shackles

Also swapped in my 3" lift pro comp shocks and ditched the rear sway bar



__________________
ZJ, Atlas 4 speed
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My buggy build....... well, continuation of a build. YELLAHEEP Colorado Chapter 39 November 17th, 2016 23:49
New Waggy 44's Build (YOUR BUILD) 98XJLongBuild Modified Tech Discussion 20 November 11th, 2011 11:19
keep the 91 or build a 00? MATTVW65 Intermountain Chapter 10 March 19th, 2007 11:48
To build or not to build mtnbikeboy OEM Tech Discussion 2 January 10th, 2005 19:35


All times are GMT -7. The time now is 18:32.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014