NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old August 4th, 2006, 17:04
jeeptree's Avatar
jeeptree jeeptree is offline
NAXJA Forum User
 
Join Date: Jul 2006
Location: Erie, Pa
Posts: 73
bad sound?

so i was driving last night in my xj it was a raining cats and dogs. big dogs! and i was hitting the water in the street at about 45mph when i heard a loud grinding sound coming from the front. it was constant i could also feel it, it wasint doing it the whole time but once it started it didnt stop. thats what got me thinking that something was wrong or that i should look at something? or is it normal?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pro sound creeperjeep Non-Tech / Off Topic 1 July 21st, 2006 22:17
What is this sound????? Dvipercop OEM Tech Discussion 9 May 18th, 2006 13:47
Does this SOund Right ? PolishX Modified Tech Discussion 1 December 28th, 2005 19:46
please help-POP sound adrnalinlovr Modified Tech Discussion 1 June 28th, 2005 23:32
Sound Bar BobCSmith OEM Tech Discussion 14 December 4th, 2004 09:25


All times are GMT -7. The time now is 04:58.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014