NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old August 3rd, 2003, 15:36
Legacy Legacy is offline
NAXJA Forum User
 
Join Date: Aug 2003
Location: Albuquerque
Posts: 128
why do i have a really low idle?

i own a 1991 xj 2wd fule injected, for the last 6 months its had a low idel well i'm sitting in traffic one day it died on me and did want to start. i replaced the o2 censor but with no luck it still has a low idel.
I'm not sure what my next step should be?
should i take it and have it tested?
thanks for any help.
Reply With Quote
  #2  
Old August 3rd, 2003, 15:41
96XJCLASSIC's Avatar
96XJCLASSIC 96XJCLASSIC is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: Hollidaysburg, PA
Posts: 490
Not exactly sure but it might be the TPS (throttle positioning sensor). Cherokee's are know for having problems with the TPS. Had to replace mine a couple months back. It was not shifting correctly and it idelled at like 300 - 500 rpms. Not sure but that is my opinion. NICK
Reply With Quote
  #3  
Old August 4th, 2003, 07:57
Greg Smith Greg Smith is offline
Jeep addict
 
Join Date: Mar 2003
Location: Spotsylvania, Virginia
Posts: 212
Try cleaning the throttle body. Greg
Reply With Quote
  #4  
Old August 4th, 2003, 08:40
Legacy Legacy is offline
NAXJA Forum User
 
Join Date: Aug 2003
Location: Albuquerque
Posts: 128
thanks, i'll check it out.
Reply With Quote
  #5  
Old August 4th, 2003, 09:42
RINGKONG RINGKONG is offline
NAXJA Forum User
 
Join Date: May 2003
Location: Nebraska
Posts: 282
TPS is a good place to look and be sure to check the IAC valve, make sure it is operational and not sticking.
Reply With Quote
  #6  
Old August 4th, 2003, 10:02
Centrevillemx Centrevillemx is offline
NAXJA Forum User
 
Join Date: Jun 2003
Location: MD's Eastern Shore
Posts: 248
Stuck throttle cable perhaps??
Reply With Quote
  #7  
Old August 5th, 2003, 09:24
Legacy Legacy is offline
NAXJA Forum User
 
Join Date: Aug 2003
Location: Albuquerque
Posts: 128
how hard is it to replace the tps?
when i'm replacing it is there any thing i should watch out for?
Reply With Quote
  #8  
Old August 6th, 2003, 12:25
Legacy Legacy is offline
NAXJA Forum User
 
Join Date: Aug 2003
Location: Albuquerque
Posts: 128
how hard is it to replace the tps?
should i just go and buy one from auto zone?
Reply With Quote
  #9  
Old August 10th, 2003, 17:23
ssnsltd's Avatar
ssnsltd ssnsltd is offline
NAXJA Forum User
 
Join Date: Jul 2003
Location: Ft. Bragg, NC
Posts: 53
Check
Here

they have them for 1/2 the dealer cost.

As to changing them out:

TPS
Reply With Quote
  #10  
Old August 11th, 2003, 07:44
Legacy Legacy is offline
NAXJA Forum User
 
Join Date: Aug 2003
Location: Albuquerque
Posts: 128
i checked out both links, but the TPS is for standard tranny and i have an auto.
thanks
Reply With Quote
  #11  
Old August 11th, 2003, 19:19
ssnsltd's Avatar
ssnsltd ssnsltd is offline
NAXJA Forum User
 
Join Date: Jul 2003
Location: Ft. Bragg, NC
Posts: 53
Check here for adjusting the with auto trans.
It is about 3/4 down the page.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent stalling (low idle) '96 4.0 4x4x4x4 OEM Tech Discussion 9 June 7th, 2005 14:40
low idle juicexj24 OEM Tech Discussion 8 November 3rd, 2004 07:54
Chevy 350, very low miles 4 bolt main mountaindrew For Sale: Private Party Only. XJ ITEMS ONLY 4 December 16th, 2003 10:06
Studder at idle jeepster1985 OEM Tech Discussion 2 December 9th, 2003 03:35
Random Idle Speeds BenXJCA OEM Tech Discussion 1 April 1st, 2003 17:41


All times are GMT -7. The time now is 19:49.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014